To obtain your registration ID "Invitation Code", please send your request to: [email protected]
Dear Respected Members, please abide by the rules of the forum and avoid posting unacceptable comments or illegal software. Thanks!
If you are a registered member in MHH and not able to login or recover your account, Kindly contact [email protected]

Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
W164 exhaust presure Sensor
12-11-2017, 12:55 PM
Post: #1
Mercedes Benz W164 exhaust presure Sensor
Hello ! I have a Problem with my w164 280cdi! Sometimes when I cold Start Mil Light comes and engine is shaking! Error Code is exhaust pressure Sensor Pressure to high! Turbo and outlet mufflers are new! Pressure Sensor is also New! Exhaust pressure is when engine is Not running at 4380hpa when running 4390 hpa! Cables are good!
Greets
Find all posts by this user
Quote this message in a reply
12-11-2017, 02:23 PM
Post: #2
RE: W164 exhaust presure Sensor
Take a look at my thread, there's lots of info there:
http://mhhauto.com/Thread-W164-320-CDI-k...ure-sensor

Hit 'Thanks' and '+Rep' if I helped plzFing32
Find all posts by this user
Quote this message in a reply
 Thanks given by: Rocinante
12-11-2017, 10:21 PM
Post: #3
RE: W164 exhaust presure Sensor
Hello

such trouble are from two different reason:
1.can be from internal barometric sensor from ecu
2.can be from air quality sensor( left side air filter housing ) also this one are the second barometric sensor

to find which one are damage you have to do a small trick:
1.start engine and disconnect air quality sensor,barometric pressure must be 1020mBar and your car must have a good responce on test drive
2.start engine and disconnect back pressure sensor and the value must be 1920-1980 mBar ( depend of sw version)

In both cases the value can be "set" in file for a standard value and no more trouble if that vehicle are somewhere 20-30 meters above the sea level!
But if the owner must go with his car in the mount area at 1800-2000m above sea level that car will have a slow responce becouse barometic pressure will be under 980mBar and the differences should not be lower/higer than 50 mBar !

Full WinOLS User
Custom ENG/GER OLS file for DPF/SCR/EGR/TVA/VSA/DTC and more...
www.quick-tuning..com
Find all posts by this user
Quote this message in a reply
 Thanks given by: KriyenKPp , JarsaR , kodi366
12-12-2017, 02:51 AM
Post: #4
RE: W164 exhaust presure Sensor
(12-11-2017 10:21 PM)mike_service Wrote:  Hello

such trouble are from two different reason:
1.can be from internal barometric sensor from ecu
2.can be from air quality sensor( left side air filter housing ) also this one are the second barometric sensor

to find which one are damage you have to do a small trick:
1.start engine and disconnect air quality sensor,barometric pressure must be 1020mBar and your car must have a good responce on test drive
2.start engine and disconnect back pressure sensor and the value must be 1920-1980 mBar ( depend of sw version)

In both cases the value can be "set" in file for a standard value and no more trouble if that vehicle are somewhere 20-30 meters above the sea level!
But if the owner must go with his car in the mount area at 1800-2000m above sea level that car will have a slow responce becouse barometic pressure will be under 980mBar and the differences should not be lower/higer than 50 mBar !

So i let the Sensors disconnected? And only adjust with diagnosis or with ecu Software? Thank you
Find all posts by this user
Quote this message in a reply
12-12-2017, 03:32 AM
Post: #5
RE: W164 exhaust presure Sensor
Only with edited software/file ! also sensor can be connected !

Full WinOLS User
Custom ENG/GER OLS file for DPF/SCR/EGR/TVA/VSA/DTC and more...
www.quick-tuning..com
Find all posts by this user
Quote this message in a reply
01-14-2018, 11:44 PM
Post: #6
RE: W164 exhaust presure Sensor
hi, run control driven turbo compressor, excessive turbo pressure compressor the car presents problem on back pressure sensor.
Find all posts by this user
Quote this message in a reply
Post Reply 


Possibly Related Threads...
Thread: Author Replies: Views: Last Post
  can l make emulator for mercedes B48 b48 seat occupancy sensor tome 14 670 Today 12:35 AM
Last Post: tome
  question radar sensor front bumper w221 shmuk 4 341 04-18-2018 10:34 PM
Last Post: stachu121
Mercedes Benz ABS error after replacement of Speed Sensor babijoe 21 1,836 04-15-2018 09:02 PM
Last Post: babijoe
Mercedes Benz SLK 171 Passenger side acceleration sensor B48/2 phydor 3 427 04-15-2018 03:54 PM
Last Post: dandhn777
  I NEED ORI FILE FOR MERCEDES W164 ML500 zvujinov 0 192 04-05-2018 02:32 AM
Last Post: zvujinov



User(s) browsing this thread:
1 Guest(s)

Return to TopReturn to Content