To obtain your registration ID "Invitation Code", please send your request to: [email protected]
Dear Respected Members, please abide by the rules of the forum and avoid posting unacceptable comments or illegal software. Thanks!
If you are a registered member in MHH and not able to login or recover your account, Kindly contact [email protected]

Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
W222 KLA problem
05-17-2018, 10:52 AM
Post: #1
Mercedes Benz W222 KLA problem
Hello guys !
I have problem with air condition in MB W222. At morning all working fine, but after some time air condition don't freezing. No have any errors in ECU. System is full. I tried change compressor and valve in system, update ECUs soft, but problem is present . Any ideas?!...
Find all posts by this user
Quote this message in a reply
05-17-2018, 11:24 AM
Post: #2
RE: W222 KLA problem
Hi,
Check the actual value for AC.
Find all posts by this user
Quote this message in a reply
05-17-2018, 11:29 AM
Post: #3
RE: W222 KLA problem
All actual values in AC ECU is OK ! I check it first !
Find all posts by this user
Quote this message in a reply
05-17-2018, 12:39 PM
Post: #4
Mercedes Benz RE: W222 KLA problem
(05-17-2018 11:29 AM)alex1972 Wrote:  All actual values in AC ECU is OK ! I check it first !

Dear Sir:
as you described information, i suggest to check the actual value of evaporator temp. sensor. As A/C system run a period, the system doesn't make cooling air anymore. possible causes are:
1. the temperature sensor detect actual temp not correct (a little higher with actual data) you can change it to make a experimental test. or you can adjust the lowest temp higher to 2 celsius degree in A/C module.
2. inspect A/C hose to locate whether anywhere frost
if i help you, please press"reputation"
Find all posts by this user
Quote this message in a reply
05-17-2018, 08:47 PM
Post: #5
RE: W222 KLA problem
All sensor is in correct values .. A/C hoses are not frosting, hoses are warm ..
Find all posts by this user
Quote this message in a reply
05-18-2018, 12:03 AM
Post: #6
RE: W222 KLA problem
does it happens only in auto mode?
if you choose max cooling the same?

Mercedes Comand/Audio antitheft codes all NTG
Mercedes Garmin Map Pilot Europe navi
Mercedes NTG5-6 Regio Software
Find all posts by this user
Quote this message in a reply
05-18-2018, 12:21 AM
Post: #7
RE: W222 KLA problem
Yes, in auto mode and in max cooling all the same ..
Find all posts by this user
Quote this message in a reply
05-18-2018, 12:23 AM
Post: #8
RE: W222 KLA problem
what are sensor temperatures

if my post was helpful - hit thanks 1087
Find all posts by this user
Quote this message in a reply
05-18-2018, 01:53 AM
Post: #9
RE: W222 KLA problem
Actual values all sensors is ok! About 18-22 °C , refrigerant pressure about 8-9 bar, but low pressure about 6 bar! About 900 mA is compressor current ..
Find all posts by this user
Quote this message in a reply
Post Reply 


Possibly Related Threads...
Thread: Author Replies: Views: Last Post
Mercedes Benz deactive vmax w222 Rayman123 14 1,818 Yesterday 12:11 PM
Last Post: Muxa797
Mercedes Benz Traffic Sign Assist on MB W222 Dollsburg 14 2,504 08-07-2018 03:25 PM
Last Post: mach1ne
Mercedes Benz W222 Instrument Cluster Dead PP2015 16 1,235 08-06-2018 11:23 PM
Last Post: Dumper
Mercedes Benz W222 N129/1 Power Electronic control Unit Faulty webmaster 0 227 06-24-2018 03:23 AM
Last Post: webmaster
Mercedes Benz Mercedes W222 (S-Class) CAN-Bus lucky1001 8 920 06-15-2018 09:23 AM
Last Post: lucky1001



User(s) browsing this thread:
1 Guest(s)

Return to TopReturn to Content