To obtain your registration ID "Invitation Code", please send your request to: [email protected]
Dear Respected Members, please abide by the rules of the forum and avoid posting unacceptable comments or illegal software. Thanks!
If you are a registered member in MHH and not able to login or recover your account, Kindly contact [email protected]

Post Reply 
 
Thread Rating:
  • 2 Votes - 3 Average
  • 1
  • 2
  • 3
  • 4
  • 5
anyone have wiring diagram? Audi q7 2012 wipers not working after motor change
09-20-2017, 02:52 AM (This post was last modified: 09-20-2017 04:31 AM by laz79.)
Post: #1
Audi anyone have wiring diagram? Audi q7 2012 wipers not working after motor change
Hello guys,

I have been given a Q7 2012 from another garage and they replaced the wiper motor due to it being seized.

Now it says on VCDS (genuine) on address 09 Central elect. :

02071 - local databus 012 electrical fault in circuit

01520 - Rain and Light Recognition Sensor (G397)
004 - no signal/no communication

00908 - Control Module For Wiper Motor
004 - No Signal/Communication

I believe this is the J400 module.

Any help guys would be really appreciated . The VCDS print shows coding in the CEM, and nobody has touched it.

I assume the rain sensor wired though the J400? I dont have a wiring diagram to help me with this?
Find all posts by this user
Quote this message in a reply
09-20-2017, 03:21 AM
Post: #2
RE: Audi q7 2012 wipers not working after motor change
Firstly make sure the bonnet switch works as it needs to be registered closed in order for the wipers to work. I presume you've checked the fuse? Usually 3 wires 1 ground, 1 fused and 1 databus signal. You can do an output test via diagnostic to see if you get a signal on the data wire. Just check linkage isn't seized too as many people replace the motor when it's actually the mechanism that's seized
Find all posts by this user
Quote this message in a reply
 Thanks given by: laz79 , KriyenKPp
09-20-2017, 03:21 AM (This post was last modified: 09-20-2017 03:23 AM by laz79.)
Post: #3
RE: Audi q7 2012 wipers not working after motor change
UPDATE:

Now i received the old wiper module and it is the same, no communication..?? Even unplugged is the same 3 faults.

No fuses are blown in any fuse box

(09-20-2017 03:21 AM)adz0101 Wrote:  Firstly make sure the bonnet switch works as it needs to be registered closed in order for the wipers to work. I presume you've checked the fuse? Usually 3 wires 1 ground, 1 fused and 1 databus signal. You can do an output test via diagnostic to see if you get a signal on the data wire. Just check linkage isn't seized too as many people replace the motor when it's actually the mechanism that's seized

Thanks, I did output test, but just says no communication. I can work washers only.

When operating the switch the CEM works correctly on output test. The mechanism is off the motor at the moment, juat wanting to see if i can get comms. Bonnet is up, but surely i would get comms even with bonnet up?
Find all posts by this user
Quote this message in a reply
09-20-2017, 03:53 AM
Post: #4
RE: Audi q7 2012 wipers not working after motor change
Sounds like you have a broken wire, you will get those codes with the module disconnected anyway. Output test may not always overide the bonnet switch so I would either bypass the switch or shut the bonnet if the wires reach up past the windscreen to output test the signal (with module plugged in)
Find all posts by this user
Quote this message in a reply
 Thanks given by: laz79 , KriyenKPp
09-20-2017, 04:12 AM
Post: #5
RE: Audi q7 2012 wipers not working after motor change
(09-20-2017 03:53 AM)adz0101 Wrote:  Sounds like you have a broken wire, you will get those codes with the module disconnected anyway. Output test may not always overide the bonnet switch so I would either bypass the switch or shut the bonnet if the wires reach up past the windscreen to output test the signal (with module plugged in)

yeah thanks again, i shut bonnet and still same. I checked on outputs and switch is working fine.

I have no other errors along the canbus, and i have a main 12 a ground and a lower voltage + all going which i assume is canbus
Find all posts by this user
Quote this message in a reply
09-20-2017, 06:18 AM
Post: #6
RE: anyone have wiring diagram? Audi q7 2012 wipers not working after motor change
nobody?
Find all posts by this user
Quote this message in a reply
09-20-2017, 06:20 AM
Post: #7
RE: anyone have wiring diagram? Audi q7 2012 wipers not working after motor change
Yes the lower voltage is the can-bus line, just be aware that even if you have a signal you can still have a blown cable. It'll carry voltage but the wrong current, I see this many times. You can check the signal and it is present but still not working, so trace the loom back and pull on the cables and generally it breaks at the problem area
Find all posts by this user
Quote this message in a reply
 Thanks given by: laz79
09-20-2017, 07:57 AM
Post: #8
RE: anyone have wiring diagram? Audi q7 2012 wipers not working after motor change
Yeah thanks. Very hard to trace wires on this car, especially with no wiring diagram! I'm wondering if the rain sensor has coincidentally failed and the wiper motor is later in the canbus and so fails as well?
Find all posts by this user
Quote this message in a reply
Post Reply 


Possibly Related Threads...
Thread: Author Replies: Views: Last Post
  VW Polo 2014 MK5 Wiring Diagram nogger 0 27 Yesterday 06:49 AM
Last Post: nogger
Audi Audi A5 8T - Change Start Screen - not work mbsupport 5 91 09-21-2017 08:13 AM
Last Post: ladadens
Audi Change Gearbox Auto to Manual on Audi A5 2013 godax 1 98 09-20-2017 12:57 AM
Last Post: ibo90
  4E0910156P can anyone help Ramis 10 334 08-29-2017 10:08 PM
Last Post: sixcode
Audi A8 cant start after ecu change BobbySD 9 330 08-02-2017 08:43 AM
Last Post: BobbySD
Seat Ibiza 2003 speedometer not work after change abs and tacho - SOLVED castin 6 272 07-28-2017 12:15 AM
Last Post: castin
  Anyone done a blind spot assist retrofit to a Golf MK7? (eGolf) phingoc 0 185 07-23-2017 01:02 PM
Last Post: phingoc
  AUDI A3 2.0 TDI DSG GEARBOX FAULT WIRING 170 iky786 2 240 07-22-2017 02:40 AM
Last Post: Flotsch
  Audi Q5 - The car only starts after OBD scan zizouth 5 231 06-22-2017 08:52 AM
Last Post: zizouth
Skoda Wiring diagram for Skoda Fabia 2015. anagram1928 0 178 06-06-2017 05:19 AM
Last Post: anagram1928



User(s) browsing this thread:
1 Guest(s)

Return to TopReturn to Content