To obtain your registration ID "Invitation Code", please send your request to: [email protected]
Please note that, guests have limited sections to view!!!
Dear Respected Members, please abide by the rules of the forum and avoid posting unacceptable comments or illegal software. Thanks!
If you are a registered member in MHH and not able to login or recover your account, Kindly contact [email protected]

Post Reply 
 
Thread Rating:
  • 3 Vote(s) - 2.67 Average
  • 1
  • 2
  • 3
  • 4
  • 5
212 E63 pulling ignition timing way back/no power
07-11-2018, 09:03 AM
Post: #1
212 E63 pulling ignition timing way back/no power
Have a 2011 W212 E63 AMG M156 here that is lacking in power in a major way. Car does not set DTC's, i've spent a good amount of time looking through actual values to find and issue to as why the car is retarding the timing (-13 degrees under load both banks)
So far ive checked-

Intake air temp
Coolant temp
Ambient temp
Oil temp
Camshaft timing (physical positions and actual values)
Check back pressure/removed down pipes
Mass air flow sensors
Fuel pressure actual and live vaules
Knock sensors, actual value, no noise repaorted
Air leakage
O2 sensors, checked under guided test
Lambda values OK
Fuel quality
Spark plugs check out ok color wise
Tested throttles under guided tests

Really at a loss of what could be telling the ME to reduce timing so far. Worth mentioning we did head bolts/gaskets about three weeks ago on this car. It's been OK up until now. I did pull the covers and check for proper camshaft alignment as well as checking the camshaft adjusters (not loose)

Any ideas would be much appricated

Ben-
Find all posts by this user
Quote this message in a reply
07-11-2018, 10:19 AM
Post: #2
RE: 212 E63 pulling ignition timing way back/no power
Are Xentry ME actual datas of engine output while kick down ok?
Any ESP/FSCU/VGS fault codes? Attach short tests.
Did you try software update?
Did coolant change color?

Mercedes Comand/Audio antitheft codes all NTG
Mercedes Garmin Map Pilot Europe navi
Mercedes NTG5-6 Regio Software
Find all posts by this user
Quote this message in a reply
 Thanks given by: Rayman123
07-11-2018, 02:58 PM
Post: #3
RE: 212 E63 pulling ignition timing way back/no power
Remove the intake manifold. And disasemble it completely. You will be surprised...
Find all posts by this user
Quote this message in a reply
 Thanks given by: Rocinante , familyman
07-12-2018, 03:09 AM (This post was last modified: 07-12-2018 03:10 AM by Duncansport.)
Post: #4
RE: 212 E63 pulling ignition timing way back/no power
(07-11-2018 10:19 AM)A2ua Wrote:  Are Xentry ME actual datas of engine output while kick down ok?
Any ESP/FSCU/VGS fault codes? Attach short tests.
Did you try software update?
Did coolant change color?

Yes
No faults in car
Yes, no flash available. SCN coded again
No, still blue

(07-11-2018 02:58 PM)MBstar78 Wrote:  Remove the intake manifold. And disasemble it completely. You will be surprised...

Thank you, will do. I did slide a scope up through the rear throttle and couldn't spot anything questionable, but definitely worth looking.
Find all posts by this user
Quote this message in a reply
07-12-2018, 03:32 AM (This post was last modified: 07-12-2018 03:33 AM by Rayman123.)
Post: #5
RE: 212 E63 pulling ignition timing way back/no power

(07-12-2018 03:09 AM)Duncansport Wrote:  
(07-11-2018 10:19 AM)A2ua Wrote:  Are Xentry ME actual datas of engine output while kick down ok?
Any ESP/FSCU/VGS fault codes? Attach short tests.
Did you try software update?
Did coolant change color?

Yes
No faults in car
Yes, no flash available. SCN coded again
No, still blue

(07-11-2018 02:58 PM)MBstar78 Wrote:  Remove the intake manifold. And disasemble it completely. You will be surprised...

Thank you, will do. I did slide a scope up through the rear throttle and couldn't spot anything questionable, but definitely worth looking.

any update my friend? i think it could be the ECU ? i dont know am just saying

Find all posts by this user
Quote this message in a reply
07-12-2018, 06:30 AM
Post: #6
RE: 212 E63 pulling ignition timing way back/no power
(07-12-2018 03:32 AM)Rayman123 Wrote:  
(07-12-2018 03:09 AM)Duncansport Wrote:  
(07-11-2018 10:19 AM)A2ua Wrote:  Are Xentry ME actual datas of engine output while kick down ok?
Any ESP/FSCU/VGS fault codes? Attach short tests.
Did you try software update?
Did coolant change color?

Yes
No faults in car
Yes, no flash available. SCN coded again
No, still blue

(07-11-2018 02:58 PM)MBstar78 Wrote:  Remove the intake manifold. And disasemble it completely. You will be surprised...

Thank you, will do. I did slide a scope up through the rear throttle and couldn't spot anything questionable, but definitely worth looking.

any update my friend? i think it could be the ECU ? i dont know am just saying

Opened up intake and all looked OK, thinking it's a ME issues at this point. Though i know as soon as i replace it the problem will still be there...
Find all posts by this user
Quote this message in a reply
07-12-2018, 06:52 AM
Post: #7
RE: 212 E63 pulling ignition timing way back/no power
Are you sure the car has not been badly remapped? Did this happen suddenly? Was anything done just before problem showed up? Or did car come to you in this state?

Please don't forget rep + thanks buttons below. It is free when you push them. Blush
Find all posts by this user
Quote this message in a reply
 Thanks given by: familyman
07-13-2018, 05:09 AM
Post: #8
RE: 212 E63 pulling ignition timing way back/no power
(07-12-2018 06:52 AM)diagnostix Wrote:  Are you sure the car has not been badly remapped? Did this happen suddenly? Was anything done just before problem showed up? Or did car come to you in this state?

Customer confirms no remap, car did this "all of a sudden". We had driven a few weeks prior and all was good.
Find all posts by this user
Quote this message in a reply
07-13-2018, 05:29 AM
Post: #9
RE: 212 E63 pulling ignition timing way back/no power
Timing chain?
Find all posts by this user
Quote this message in a reply
Post Reply 


Possibly Related Threads...
Thread: Author Replies: Views: Last Post
Mercedes Benz Mercedes 205 power steering headlights problem elwis272 12 1,496 09-14-2018 08:40 PM
Last Post: elwis272
Mercedes Benz [Solution] Xentry Diagnostics OpenShell (9.2018) Rolling Back Installation Fouad 2 448 09-12-2018 10:33 PM
Last Post: Fouad
Mercedes Benz mercedes w221 blower runs when ignition off!! reevacenter 12 1,287 09-02-2018 11:33 AM
Last Post: musta60
  Om904/906 timing question Efmang 0 92 08-30-2018 01:15 PM
Last Post: Efmang
  MB Star C3 problem error uart CAN1 power marx232 11 182 08-29-2018 01:44 PM
Last Post: kaype



User(s) browsing this thread:
1 Guest(s)

Return to TopReturn to Content